Odysseus 0.8.2 - Public

Discussion of general (non platform specific) MailForge topics including feature requests

Odysseus 0.8.2 - Public

Postby Matt Milano » Mon May 12, 2008 4:21 pm

**PLEASE DO NOT POST ANY DOWNLOAD LINKS TO SITES SUCH AS MACUPATE OR VERSIONTRACKER**

Hi Everyone,

Odysseus 0.8.2 is now available to the general public. One disclaimer that we would like to make sure everyone understands. This is a VERY EARLY beta. Under normal circumstances, we would prefer not to release this early of a build. However, given the issues that many people are having with Eudora®, we felt it necessary to show everyone the direction Odysseus is taking, specifically how close it's holding to the Eudora® user experience.

That being said, we DO NOT recommend using this build for anything other than testing. It is not designed to be used in a mission-critical environment.


RELEASE Notes

Fixes

- Issue When Replying, Forwarding, Redirecting
- Issue Initializing Built-In Address Book

Features Currently Operational

- Receiving Email
- Sending Email
- Downloading Attachments
- Multiple Accounts
- Built-in Address Book
- Transferring Email Across Mailboxes
- Replying, Forwarding, Redirecting
- Basic Email Filtering (set default mailbox for each account if desired)
- Basic Attachment Filtering (can define specific Attachment folder per email account)
- HTML Rendering (via the File Menu. A future build will allow this to be enabled as On or Off by default)
- Importing Eudora Email

What Is Not Operational
**In many cases, the features below are already implemented to some degree, they are simply not accessible via the interface**

- IMAP (This has actually been implemented for a couple of builds. We have it disabled in this build as we improve it a bit more)
- Signatures (This is largely done but disabled)
- Stationery (This is largely done but disabled)
- OS X Address Book Integration (This is largely done but disabled)
- Sending Attachments (In progress)
- Spelling
- Gmail Support (In progress - this has been long-standing issue dating back to the Private Betas that we are addressing)
- Advanced Features (Most are already in various states of completion)
- Documentation


Now that Odysseus has moved to Public Beta, we will be releasing updates on a daily basis as we move closer to our revised June timeframe. Even if they are relatively minor, each build will fix bugs and/or integrate the missing functionality.

Again, we would like to stress that this is a VERY EARLY beta. There are bugs, and a lot of work to still be done. This IS NOT intended for every day use. This is strictly to show the Eudora community the direction Odysseus is moving in.

Here's the links:

Mac OS X
http://www.infinitydatasystems.com/file ... ysseus.zip

Windows
Coming Soon. We're working on a couple of interface bugs specific to Windows.
Matt Milano
Project Manager
Infinity Data Systems

Skype & Twitter:
InfinityData
Matt Milano
Site Admin
 
Posts: 1587
Joined: Fri Sep 07, 2007 12:49 am

Re: Odysseus 0.8.2 - Public

Postby tdiaz » Mon May 12, 2008 4:41 pm

Woohoo!! .. but .. G.. no Mail.

Ironic that cranky old Eudora itself works with Gmail.
tdiaz
 
Posts: 385
Joined: Fri Nov 23, 2007 4:00 pm

Re: Odysseus 0.8.2 - Public

Postby Anestis » Mon May 12, 2008 4:46 pm

Matt Milano wrote:What Is Not Operational
**In many cases, the features below are already implemented to some degree, they are simply not accessible via the interface**
- Gmail Support (In progress - this has been long-standing issue dating back to the Private Betas that we are addressing)


Matt,

Since the private Betas, GMail has been a big issue, since it is my primary, and usually only, way of communicating with people. I felt a little useless as part of the private beta, as I could not test the software fully.

I assume many others in the real world are in the same boat. On many mailing lists, more and more people are moving to GMail. If Oysseus cannot access GMail, it will be useless for them, and your sales figures will not be as optimistic as you think.

releasing a public beta without proper GMail support is a bad idea, in my opinion. It will instantly receive low marks in many reviews because of this, and will discourage people from trying it.

You mentioned fixes were under way, but it still seems to be an issue. Is Gmail ever going to work?

I actually have 2 Gmail accounts, one personal, one for business.

Anestis.
Anestis
 
Posts: 80
Joined: Tue Dec 11, 2007 4:49 am
Location: Melbourne, Australia

Re: Odysseus 0.8.2 - Public

Postby ltking@hawaii.rr.com » Mon May 12, 2008 4:50 pm

Matt & Crew:

For a program just "out of the bakery," I am impressed!

I would like to ask how I tell the program to leave all mail on my current ISP e-mail server when I actually (in the future) ask it to retrieve my mail. On my initial race through the program I did not find this under the preferences pane where I expected it.

I am looking forward to using this program.

Cheers,
Lonnie
ltking@hawaii.rr.com
 
Posts: 201
Joined: Wed Apr 16, 2008 11:38 pm

Re: Odysseus 0.8.2 - Public

Postby Matt Milano » Mon May 12, 2008 4:52 pm

Regarding Gmail... Yes it will work. In our test builds we've made significant progress in communicating with Gmail's servers. We just have the final hurdle to overcome. We're hoping to have it overcome by tomorrow's build.

Regarding leaving mail on the server... At this point Odysseus CANNOT DELETE mail from the server. Because this is a beta, and therefore we're not encouraging people to use it for mission-critical use, we have no intention of even enabling the ability to delete email from the server until the final builds in June.
Matt Milano
Project Manager
Infinity Data Systems

Skype & Twitter:
InfinityData
Matt Milano
Site Admin
 
Posts: 1587
Joined: Fri Sep 07, 2007 12:49 am

Re: Odysseus 0.8.2 - Public

Postby irene » Mon May 12, 2008 5:38 pm

Is this where we tell you bout bugs we encounter?

When I attempt to REPLY to a message the program "experienced an unrecoverable error."

This happens every time.
irene
 
Posts: 8
Joined: Mon Oct 22, 2007 4:16 pm

V. 8.2 - still no functionality for me

Postby paul-ny » Mon May 12, 2008 5:56 pm

Maybe there is corruption in my computer? Or something I am doing completely wrong? Can't think what.

As with the earlier betas, I found that Odysseus does not connect to my email servers to send or receive. I just get a spinning barber pole of a progress bar. On sending mail, it says "sending [subject of email]" over the progress bar, and on checking mail it says nothing.

I'm also unable to attach files to an email; the Attach button doesn't do anything and the Message>Attach Document menu item is grayed out when I am composing a message.

Happily, now the mailboxes appear as they should when I click on their icon in the Mailboxes window and they don't get mixed up with each other, though a new outgoing message doesn't seem to appear in the open Out mailbox unless the mailbox is closed and reopened.

But all of this is minor compared to my not being able to actually get or send anything.

I'm using Odysseus 0.8.2 on a PowerBook G4 800, running OS 10.4.11, using AT&T's Worldnet DSL (not their Yahoo DSL) as ISP.

I just tried creating a second account in Odysseus to get mail that I have only accessed online and never through a POP connection; this is not an AT&T email but email from my website's servers, at frognet.net. The same thing happens; no connection is made to the servers, POP or SMTP.
paul-ny
 
Posts: 257
Joined: Fri Feb 01, 2008 2:51 pm
Location: New York

Re: V. 8.2 - still no functionality for me

Postby Matt Milano » Mon May 12, 2008 5:58 pm

paul-ny wrote:Maybe there is corruption in my computer? Or something I am doing completely wrong? Can't think what.

As with the earlier betas, I found that Odysseus does not connect to my email servers to send or receive. I just get a spinning barber pole of a progress bar. On sending mail, it says "sending [subject of email]" over the progress bar, and on checking mail it says nothing.

I'm also unable to attach files to an email; the Attach button doesn't do anything and the Message>Attach Document menu item is grayed out when I am composing a message.

Happily, now the mailboxes appear as they should when I click on their icon in the Mailboxes window and they don't get mixed up with each other, though a new outgoing message doesn't seem to appear in the open Out mailbox unless the mailbox is closed and reopened.

But all of this is minor compared to my not being able to actually get or send anything.

I'm using Odysseus 0.8.2 on a PowerBook G4 800, running OS 10.4.11, using AT&T's Worldnet DSL (not their Yahoo DSL) as ISP.

I just tried creating a second account in Odysseus to get mail that I have only accessed online and never through a POP connection; this is not an AT&T email but email from my website's servers, at frognet.net. The same thing happens; no connection is made to the servers, POP or SMTP.


We'll take a look at the issue with AT&T servers. It sounds like they could be communicating in the same fashion as Gmail, meaning that the Gmail fix could fix your issue as well. We're trying to get the last hurdle to the Gmail issue fixed in time for the build tomorrow. I'll be curious to see if that works for you.
Matt Milano
Project Manager
Infinity Data Systems

Skype & Twitter:
InfinityData
Matt Milano
Site Admin
 
Posts: 1587
Joined: Fri Sep 07, 2007 12:49 am

Re: Odysseus 0.8.2 - Public

Postby Matt Milano » Mon May 12, 2008 6:00 pm

irene wrote:Is this where we tell you bout bugs we encounter?

When I attempt to REPLY to a message the program "experienced an unrecoverable error."

This happens every time.


Are you using 0.8.1 or 0.8.2?
Matt Milano
Project Manager
Infinity Data Systems

Skype & Twitter:
InfinityData
Matt Milano
Site Admin
 
Posts: 1587
Joined: Fri Sep 07, 2007 12:49 am

Re: Odysseus 0.8.2 - Public

Postby rmillstein » Mon May 12, 2008 6:03 pm

Matt Milano wrote:
irene wrote:Is this where we tell you bout bugs we encounter?

When I attempt to REPLY to a message the program "experienced an unrecoverable error."

This happens every time.


Are you using 0.8.1 or 0.8.2?

I also get this error, using 0.8.2.

Roberta
Eudora user since ~1995. Waiting and seeing on MailForge.
rmillstein
 
Posts: 83
Joined: Tue Sep 11, 2007 12:55 am

Next

Return to MailForge - General

Who is online

Users browsing this forum: No registered users and 1 guest

cron